Системные требования

Материал из ФабрикаСайтов

(Различия между версиями)
Перейти к: навигация, поиск
(Для корректной работы Ф.CMS хостинг должен соответствовать следующим требованиям:)
 
(11 промежуточных версий не показаны.)
Строка 1: Строка 1:
-
==Для корректной работы Ф.CMS хостинг должен соответствовать следующим требованиям:==
+
==Для корректной работы панели администратора сайта хостинг должен соответствовать следующим требованиям:==
-
* Веб-сервер: Apache 2.2 и выше с поддержкой модуля mod_rewrite (требуется для работы ЧПУ).
+
* ОС: Linux
-
* Версия PHP: 5.3.x и выше
+
* Веб-сервер: Apache 2.2 и выше с поддержкой модуля mod_rewrite.
 +
* Версия PHP: 5.4.х и выше
* Должны быть подключены следующие модули PHP: pdo, pdo_mysql, gd, dom, xml, zip, zlib, mbstring, iconv, curl
* Должны быть подключены следующие модули PHP: pdo, pdo_mysql, gd, dom, xml, zip, zlib, mbstring, iconv, curl
* Данные параметры интерпретатора PHP должны быть отключены:
* Данные параметры интерпретатора PHP должны быть отключены:
-
* safe_mode
+
safe_mode
-
* register_globals
+
register_globals
-
* magic_quotes_gpc
+
magic_quotes_gpc
* Версия MySQL: 5.1.x и выше
* Версия MySQL: 5.1.x и выше
* Для отправки почты должен быть разрешен доступ к функции mail()
* Для отправки почты должен быть разрешен доступ к функции mail()
 +
* В целях оптимизации работы с сессиями рекомендуется включить в настойках php параметр session.gc_probability
 +
* Для работы мультиязычных сайтов необходима возможность указания для сайта дополнительных адресов (алиасы/синонимы), а также возможность создать поддомен для этих синонимов в DNS
==Работа с администраторской панелью сайта поддерживается в следующих браузерах:==
==Работа с администраторской панелью сайта поддерживается в следующих браузерах:==
Строка 15: Строка 18:
* Mozilla Firefox 3.0 и выше
* Mozilla Firefox 3.0 и выше
* Apple Safari 3.1.2 и выше
* Apple Safari 3.1.2 и выше
-
* Microsoft Internet Explorer 8 и выше
 

Текущая версия на 12:35, 24 января 2017

Для корректной работы панели администратора сайта хостинг должен соответствовать следующим требованиям:

  • ОС: Linux
  • Веб-сервер: Apache 2.2 и выше с поддержкой модуля mod_rewrite.
  • Версия PHP: 5.4.х и выше
  • Должны быть подключены следующие модули PHP: pdo, pdo_mysql, gd, dom, xml, zip, zlib, mbstring, iconv, curl
  • Данные параметры интерпретатора PHP должны быть отключены:
safe_mode
register_globals
magic_quotes_gpc
  • Версия MySQL: 5.1.x и выше
  • Для отправки почты должен быть разрешен доступ к функции mail()
  • В целях оптимизации работы с сессиями рекомендуется включить в настойках php параметр session.gc_probability
  • Для работы мультиязычных сайтов необходима возможность указания для сайта дополнительных адресов (алиасы/синонимы), а также возможность создать поддомен для этих синонимов в DNS

Работа с администраторской панелью сайта поддерживается в следующих браузерах:

  • Google Chrome
  • Mozilla Firefox 3.0 и выше
  • Apple Safari 3.1.2 и выше
Личные инструменты